
Google SketchUp 8 Handbook 1 

SketchUp 8 Handbook.indd   1 26/4/2554   10:21:57



2 Google SketchUp 8 Handbook

Google SketchUp Concepts
	 Google SketchUp เป็นโปรแกรมสำ�หรับสร้างแบบจำ�ลอง 3D (Three-Dimensional) ที่มีความง่ายต่อการใช้งาน และเป็นที่

นิยมอย่างกว้างขวาง โดยส่วนใหญ่จะถูกนำ�มาใช้ในงานออกแบบเชิงสถาปัตยกรรม งานออกแบบภายในและภายนอก การออกแบบ

กลไกการทำ�งานของเครื่องจักร เฟอร์นิเจอร์ ภูมิประเทศ ผลิตภัณฑ์ รวมไปถึงงานออกแบบฉาก อาคาร และสิ่งก่อสร้างในเกม หรือจะ

เป็นการจัดฉากทำ� Story Boards ในงานภาพยนต์หรือละครโทรทัศน์ก็สามารถทำ�ได้

	 นอกจากนี้ยังทำ�งานร่วมกับปลั๊กอิน (Plugin) ต่างๆที่ถูกพัฒนาเพื่อช่วยเพิ่มประสิทธิภาพในการทำ�งานของ Google 

SketchUP ให้สูงขึ้น ไม่ว่าจะเป็นปลั๊กอินที่ช่วยให้การสร้างรูปทรงต่างๆสามารถทำ�ได้ง่ายขึ้น ไปจนถึงปลั๊กอินที่ช่วยในการจัดแสงเงา

ให้ดูสมจริงอย่างเช่น V-Ray หรือ Podium เป็นต้น

ความต้องการของระบบ
	 Google SketchUp เป็นโปรแกรมที่มีความสามารถสูง แต่กลับมีความต้องการระบบต่ำ� แต่อย่างไรก็ตามในการทำ�งาน

กับโมเดลที่มีความซับซ้อนมาก เครื่องคอมพิวเตอร์ก็จำ�เป็นที่จะต้องมีความเร็วพอสมควรเพื่อให้การแสดงผลและการทำ�งานเป็นไป

อย่างลื่นไหล โดยทาง Google ได้กำ�หนดความต้องการของระบบเอาไว้ดังนี้

ความต้องการขั้นต่ำ�ของระบบ

ระบบปฎิบัติการ Microsoft Windows(R) XP / Vista / 7

ความเร็ว CPU 1 GHz 

หน่วยความจำ� RAM 512 MB สำ�หรับ XP และ 1 GB สำ�หรับ Vista / 7

เนื้อที่ว่างใน Hard-disk 300 MB สำ�หรับการติดตั้งโปรแกรม

การ์ดแสดงผล มีหน่วยความจำ� 128 MB สำ�หรับ XP และ 256 MB สำ�หรับ Vista / 7 และสนับสนุน 

การทำ�งานกับ OpenGL ตั้งแต่เวอร์ชัน 1.5 ขึ้นไป

เม้าส์ แบบ 3 ปุ่ม มีล้อหมุน

ซอฟท์แวร์ที่จำ�เป็น Microsoft Service Pack 2 ขึ้นไปสำ�หรับ XP, Microsoft(R) Internet Explorer 7.0 

ขึ้นไป และ .NET Framework เวอร์ชัน 2.0 สำ�หรับการใช้งาน Google SketchUp Pro

ความต้องการของระบบที่แนะนำ�

ระบบปฎิบัติการ Microsoft Windows(R) XP / Vista / 7

ความเร็ว CPU ตั้งแต่ 2 GHz ขึ้นไป  

หน่วยความจำ� RAM ตั้งแต่ 2 GB ขึ้นไป

เนื้อที่ว่างใน Hard-disk 500 MB สำ�หรับการติดตั้งโปรแกรม

การ์ดแสดงผล มีหน่วยความจำ�ตั้งแต่ 512 MB ขึ้นไป และสนับสนุนการทำ�งานกับ OpenGL ตั้งแต่

เวอร์ชัน 1.5 ขึ้นไป

เม้าส์ แบบ 3 ปุ่ม มีล้อหมุน

ซอฟท์แวร์ที่จำ�เป็น Microsoft Service Pack 2 ขึ้นไปสำ�หรับ XP, Microsoft(R) Internet Explorer 7.0 

ขึ้นไป และ .NET Framework เวอร์ชัน 2.0 สำ�หรับการใช้งาน Google SketchUp Pro

	 สามารถตรวจสอบรายละเอียดเพิ่มเติมเกี่ยวกับความต้องการของระบบได้ที่ http://sketchup.google.com/support/bin/

answer.py?answer=36208&&hl=en

หมายเหตุ: สำ�หรับการติดตั้ง Google SketchUp Pro ถ้าในเครื่องไม่มีการติดตั้ง .NET Framework 2.0 เอาไว้ก่อน ระบบจะมีการ

ร้องขอและจะทำ�การดาวน์โหลดและติดตั้งให้โดยอัตโนมัติ
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เริ่มต้นกับ Google SketchUp 8
รู้จักกับส่วนประกอบต่างๆของโปรแกรม
	 ในการเปิดโปรแกรม Google SketchUp ครั้งแรก (หลังจากการติดตั้งโปรแกรม และเลือกแม่แบบในหน้าต่าง Welcome 

แล้ว) เราจะพบกับหน้าตาของโปรแกรมโดยมีส่วนประกอบหลักดังนี้

Title Bar (แถบไตเติล)

	 แถบสำ�หรับแสดงชื่อไฟล์ที่กำ�ลังทำ�งานอยู่ในขณะนั้น โดยในการเปิดโปรแกรมหรือสร้างงานขึ้นมาใหม่ ชื่อไฟล์บนแถบไต

เติ้ลจะแสดงเป็น Untitled จนกว่าจะมีการบันทึกและตั้งชื่อไฟล์

Menu Bar (แถบเมนู)

	 แถบที่รวบรวมคำ�สั่งต่างๆในการทำ�งาน โดยจะแบ่งออกเป็น 8 หมวดด้วยกันดังนี้

	 File: เป็นกลุ่มคำ�สั่งสำ�หรับจัดการกับไฟล์งานเช่น การสร้างไฟล์งาน เปิดไฟล์งาน การบันทึก การนำ�เข้า/ส่งออก การสั่งพิมพ์ 

เป็นต้น

	 Edit: เป็นกลุ่มคำ�สั่งสำ�หรับปรับแต่งแก้ไขเช่น การคัดลอก ลบ ซ่อน/แสดงวัตถุ สร้าง Group/Component เป็นต้น

	 View: เป็นกลุ่มคำ�สั่งสำ�หรับจัดการในส่วนของพื้นที่ทำ�งานเช่น ซ่อน/แสดงแถบเครื่องมือ เส้นไกด์ แกนอ้างอิง เงา หมอก 

การแสดงผลของเส้น การแสดงผลในส่วนของการแก้ไข Group/Component เป็นต้น

	 Camera: เป็นกลุ่มคำ�สั่งสำ�หรับจัดการในส่วนของมุมมองในการทำ�งานเช่น การหมุน เลื่อน ย่อ/ขยาย เป็นต้น

	 Draw: เป็นกลุ่มคำ�สั่งสำ�หรับเรียกใช้เครื่องมือต่างๆในการวาดรูปทรงเช่น กาววาดเส้นตรง เส้นโค้ง สี่เหลี่ยม วงกลม เป็นต้น

	 Tools: เป็นกลุ่มคำ�สั่งสำ�หรับเรียกใช้เครื่องมือต่างๆในการทำ�งานเช่น Push/Pull การหมุน/ย้ายวัตถุ การสร้างตัวอักษรสาม

มิติ การวัดขนาด เป็นต้น

	 Window: เป็นกลุ่มคำ�สั่งเกี่ยวกับการเรียกแสดงหน้าต่างหรือไดอะล็อกบอกซ์ขึ้นมาเพื่อใช้ร่วมในการทำ�งานและปรับแต่งค่า

ต่างๆของโปรแกรม

	 Help: เป็นกลุ่มคำ�สั่งเกี่ยวกับคู่มือการแนะนำ�การใช้งานโปรแกรม ไปจนถึงการลงทะเบียนและการตรวจสอบการอัพเดต

Title Bar

Menu Bar

Toolbars

Drawing Area

Drawing Axes

Status Bar Measurement

(VCB Control)

Dialog Baxes
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Toolbars (แถบเครื่องมือ)

	 แถบสำ�หรับรวบรวมเครื่องมือต่างๆในการทำ�งาน โดยในขั้นต้นโปรแกรมจะกำ�หนดแถบเครื่องมือมาให้กลุ่มเดียว (จาก 20 

กลุ่ม) คือ Getting Start ซึ่งในการทำ�งานจริงเครื่องมือเพียงเท่าน้ีไม่เพียงพอต่อการทำ�งาน เราสามารถที่จะเรียกแสดงแถบเครื่องมือ

กลุ่มต่างๆได้จากเมนู View > Toolbars แล้วเลือกแถบเครื่องมือที่ต้องการ โดยแถบเครื่องมือที่แสดงอยู่จะมีเครื่องหมายถูกอยู่ที่หน้า

คำ�สั่ง

	 เพื่อความสะดวกในการทำ�งานแนะนำ�ให้เรียกแสดงแถบเครื่องมือดังภาพตัวอย่าง ซึ่งเป็นกลุ่มเครื่องมือที่มักจะถูกใช้งาน

เป็นประจำ�ในการสร้างแบบจำ�ลองสามมิติในเบื้องต้น

Drawing Area (พื้นที่ทำ�งาน)

	 เป็นพื้นที่สำ�หรับทำ�งานซึ่งสามารถที่จะปรับเปลี่ยนมุมมองไปเป็นมุมมองต่างๆ ทั้งในการทำ�งานในมุมมองแบบ 2D และ 3D 

โดยมุมมองแบบ 2D นั้นจะแบ่งออกเป็นด้านบน ด้านหน้า ด้านขวา ด้านหลัง ด้านซ้าย และด้านล่าง และมุมมองแบบ 3D จะถูกเรียก

ว่า Iso (Isometric)

Drawing Axes (แกนอ้างอิง)

	 คือเส้นแกนสำ�หรับอ้างอิงการทำ�งานเพื่อให้การวาด

รูปทรงและการสร้างแบบจำ�ลองในทิศทางต่างๆเป็นไปอย่าง

ถูกต้องและแม่นยำ� โดยแกนอ้างอิงจะแบ่งออกเป็น 3 แกน

ด้วยกันคือ x จะอยู่ในลักษณะของแนวขวาง (แกนสีแดง), y 

จะอยู่ในลักษณะของแนวลึก (แกนสีเขียว) และ z จะอยู่ใน

ลักษณะของแนวตั้ง (แกนสีน้ำ�เงิน)

	 จุดตัดกันระหว่างเส้นแกนทั้ง 3 เส้นจะถูกเรียกว่า 

Original Point หรือจะเรียกว่าจุดศูนย์กลางของพื้นที่ทำ�งาน

ก็ได้เช่นกัน โดยตำ�แหน่งของ Original Point จะมีค่า x, y, z 

เท่ากับ 0 โดยถ้าค่าตัวเลขเป็นบวกจะอยู่ในทิศทางของเส้น

ทึบ และถ้าค่าเป็นลบจะอยู่ในทิศทางของเส้นจุดไข่ปลา

Large Tool Set

Standard Style

Views

กำ�หนดให้แสดงไอคอนของแถบเครื่องมือขนาดใหญ่

Solid Tools
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Status Bar (แถบสถานะ)

	 คือแถบแสดงสถานะต่างๆในการทำ�งาน โดยจะแสดงในส่วนการแนะนำ�การใช้งานเครื่องมือต่างๆที่จะเปลี่ยนไปตามการทำ�

งานและการใช้เครื่องมือแต่ละชนิด ใน Google SketchUp ตั้งแต่เวอร์ชัน 7 เป็นต้นมาได้มีการเพิ่มไอคอนในส่วนของการทำ�งานร่วม 

กับระบบออนไลน์เข้ามาไว้เพื่อให้สะดวกกับการแชร์ผลงานไปยัง Google 3D Warehouse และกำ�หนดตำ�แหน่งจริงบนแผ่นดินให้กับ

แบบจำ�ลองด้วย นอกจากนี้ยังเพิ่มเติมในส่วนของไอคอน Help ที่จะช่วยเรียกแสดงหน้าต่าง Instructor ขึ้นมาเพื่อแนะนำ�การใช้งาน

เครื่องมือต่างๆอีกด้วย

Dialog Boxes (กล่องเครื่องมือ)

	 Dialog Boxes จะมีชื่อเรียกอยู่หลายชื่อด้วยกันเช่น Window หรือ Panel ขอเรียกรวมๆว่าหน้าต่างเพื่อความกระชับ โดยจะมี

ลักษณะเป็นหน้าต่างเครื่องมือสำ�หรับปรับแต่งแก้ไขรายละเอียดในการทำ�งาน และกำ�หนดค่าต่างๆของโปรแกรม เช่น หน้าต่าง Sys-

tem Preferences จะเป็นหน้าต่างสำ�หรับกำ�หนดค่าต่างๆของโปรแกรม, หน้าต่าง Materials จะเป็นหน้าต่างที่รวบรวมเอาวัสดุต่างๆ

เพื่อนำ�ไปใส่ให้กับพื้นผิวของโมเดล (นิยมเรียกกันว่าการใส่แมท), หน้าต่าง Shadow Settings จะเป็นส่วนสำ�หรับการกำ�หนดทิศทาง

ของแสง/เงาเป็นต้น

	 การเรียกแสดงหน้าต่างแต่ละชนิดสามารถเรียกได้จากเมนู Window แล้วเลือกเปิดหน้าต่างที่ต้องการ โดยหน้าต่างที่เปิดอยู่ 

จะมีเครื่องหมายถูกกำ�กับไว้อยู่ที่หน้าคำ�สั่ง (เฉพาะหน้าต่างที่เก่ียวกับการปรับแต่งโมเดล) และถ้ามีเครื่องหมายขีดอยู่ด้านหน้าจะ

หมายถึงหน้าต่างนั้นเปิดอยู่แต่ถูกย่อเอาไว้เหลือเพียงแถบไตเติล

Measurment Tool (เครื่องมือกำ�หนดขนาด)

	 Measurment มีชื่อเรียกอีกชื่อหนึ่งว่า VCB (Value Control Box) เป็น

เครื่องมือสำ�หรับกำ�หนดค่าต่างๆ ไม่ว่าจะเป็นความยาว ขนาด องศา ระยะ ให้

กับการใช้งานเครื่องมือต่างๆซึ่งจะช่วยให้การสร้างแบบจำ�ลองมีความแม่นยำ�

และได้สัดส่วนที่ถูกต้อง โดยรูปแบบการกำ�หนดค่าด้วย Measurment นั้นจะ

ใช้วิธีการพิมพ์ตัวเลขลงไปในขณะที่ใช้เครื่องมือแต่ละชนิดอยู่โดยที่ไม่ต้องเอา

เม้าส์ไปคลิกที่ช่องกำ�หนดค่า เช่นเมื่อเราต้องการวาดรูปสี่เหลี่ยมขนาด 5 x 

5 เมตร เราจะใช้เครื่องมือ Rectangle วาดรูปสี่เหลี่ยม จากนั้นพิมพ์ค่าลงไป

เป็น 5m,5m หรือ 5,5 (ในกรณีที่กำ�หนดหน่วยวัดเป็นเมตรไม่จำ�เป็นที่จะต้อง

ใส่หน่วยวัดต่อท้ายตัวเลข) แล้วเคาะ Enter เราก็จะได้รูปสี่เหลี่ยมขนาด 5 x 5 

เมตรเป็นต้น
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เครื่องมือสำ�หรับจัดการมุมมอง
	 ในการสร้างแบบจำ�ลองสามมิติเราจำ�เป็นที่จะต้องปรับมุมมองไปในทิศทางต่างๆเพื่อให้สามารถสร้างวัตถุในทิศทางต่างๆ

ได้ โดยเราสามารถที่จะควบคุมและปรับเปลี่ยนมุมมองได้ด้วยการใช้เครื่องมือต่างๆที่โปรแกรมมีมาให้ โดยเครื่องมือหลักๆสำ�หรับ

การควบคุมมุมมองจะมีด้วยกันดังนี้

เครื่องมือ ไอคอน คีย์ลัด หน้าที่

Orbit O ปรับหมุนมุมมอง

Pan H เลื่อนมุมมอง

Zoom Z ย่อ/ขยายมุมมอง

Zoom Extents Ctrl+Shift+E ขยายวัตถุทั้งหมดให้พอดีกับหน้าจอ

Zoom Window Ctrl+Shift+W ขยายวัตถุแบบกำ�หนดขอบเขต

Previous - มุมมองก่อนหน้า

Next - มุมมองถัดไป

Position Camera - กำ�หนดตำ�แหน่งของมุมมอง

Look Around - เลื่อนมุมมองไปรอบๆแบบใช้สายตามอง

Walk - เลื่อนมุมมองไปยังตำ�แหน่งที่ต้องการแบบการเดิน

Iso - มุมมองแบบ Isometric (3D)

Top - มุมมองด้านบน

Front - มุมมองด้านหน้า

Right - มุมมองด้านขวา

Back - มุมมองด้านหลัง

Left - มุมมองด้านซ้าย

การควบคุมมุมมองด้วยเม้าส์และคีย์บอร์ด
	 เพื่อช่วยให้การทำ�งานมีความสะดวกและรวดเร็ว เรายังสามารถที่จะควบคุมมุมมองในขณะทำ�งานด้วยเครื่องมือต่างๆได้

ด้วยการใช้เม้าส์ร่วมกับคีย์บอร์ดโดยมีรูปแบบการใช้งานดังนี้

การปรับหมุนมุมมอง คลิกที่ลูกกลิ้งของเม้าส์ เครื่องมือจะถูกเปลี่ยนเป็นเครื่องมือ Orbit ชั่วคราว

การเลื่อนมุมมอง คลิกที่ลูกกลิ้งของเม้าส์พร้อมกดคีย์ Shift เครื่องมือจะถูกเปลี่ยนเป็นเครื่องมือ Pan ชั่วคราว

การย่อ/ขยาย หมุนลูกกลิ้งไปข้างหน้าจะเป็นการขยาย หมุนมาด้านหลังจะเป็นการย่อ

	 ในขณะที่เลือกเครื่องมือ Orbit, Pan และ Zoom สามารถที่จะคลิกเม้าส์ปุ่มขวาเพื่อ

เรียกแสดงเมนูคำ�สั่งสำ�หรับการควบคุมมุมมองได้อีกด้วย

Tips: ในขณะที่ใช้เครื่องมือ Orbit, Pan, Look Around, Walk หรือ Zoom การกดปุ่ม Esc หรือ

คลิกขวาเลือกคำ�สั่ง Exit เครื่องมือจะถูกเปลี่ยนไปเป็นเครื่องมือก่อนหน้าที่ถูกเลือกใช้งาน

หมายเหตุ: ในกรณีที่ใช้เครื่องมือใดๆอยู่ แล้วทำ�การเปลี่ยนเครื่องมือเป็น Orbit หรือ Pan 

ชั่วคราว ซึ่งขณะนั้นจะมีการคลิกเม้าส์ปุ่มกลางอยู่ก็ให้คลิกเม้าส์ปุ่มขวาเพื่อเรียกแสดงเมนูได้

โดยจะต้องไม่ปล่อยเม้าส์ปุ่มกลาง
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การกำ�หนดคุณสมบัติของโปรแกรม
	 การกำ�หนดคุณสมบัติของโปรแกรมจะกระทำ�ผ่านหน้าต่าง System Preferences สามารถเรียกแสดงได้จากเมนู Window > 

Preferences โดยในหน้าต่าง System Preferences จะแบ่งหมวดการกำ�หนดค่าออกเป็น 10 หมวดด้วยกันคือ 

Applications เป็นส่วนสำ�หรับการกำ�หนดโปรแกรมพื้นฐานในการแก้ไขไฟล์รูปภาพ

Compatbility เป็นส่วนสำ�หรับกำ�หนดการไฮไลท์ของ Component/Group และรูปแบบการหมุนของลูกกลิ้งเม้าส์

Drawing เป็นส่วนสำ�หรับกำ�หนดรูปแบบการวาดเส้นตรง การแสดงผล Crosshairs และเครื่องมือ Push/Pull

Extensions เป็นส่วนสำ�หรับเปิด/ปิดการทำ�งานของปลั๊กอิน

Files เป็นส่วนสำ�หรับกำ�หนดไดเรกทอรีของไฟล์

General เป็นส่วนสำ�หรับกำ�หนดค่าทั่วไปเช่น การบันทึกไฟล์ การแก้ปัญหาของโมเดลเป็นต้น

OpenGL เป็นส่วนสำ�หรับกำ�หนดค่าการแสดงผลในส่วนของ OpenGL

Shortcuts เป็นส่วนสำ�หรับกำ�หนดคีย์ลัดในการใช้งานคำ�สั่งต่างๆ

Template เป็นส่วนสำ�หรับเลือกแม่แบบเริ่มต้นที่จะใช้ในการทำ�งาน

Workspace เป็นส่วนสำ�หรับคืนค่าพื้นที่ทำ�งานและกำ�หนดขนาดไอคอนของเครื่องมือ

กำ�หนดค่า Keyboard Shortcut
	 Google SketchUp ได้กำ�หนดค่าในส่วนของ Keyboard Shortcut หรือคีย์ลัดเอาไว้ให้แล้วส่วนหนึ่ง เราสามารถที่จะกำ�หนด

ค่าของคีย์ลัดตามความถนัดในการใช้งานของตัวเองได้จากหน้าต่าง System Preferences ขึ้นมาแล้วเลือกไปที่ Shortcuts โดยจะมี

ส่วนสำ�หรับกำ�หนดค่าดังนี้
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Filter ใช้สำ�หรับกรองหาคำ�สั่งที่ต้องการ

Function เป็นส่วนสำ�หรับแสดงรายการคำ�สั่งทั้งหมดที่มีในโปรแกรม

Add Shortcut ใช้สำ�หรับกำ�หนดคีย์ลัดที่ต้องการ

Assigned แสดงคีย์ลัดของคำ�สั่งที่ถูกกำ�หนดเอาไว้

+ เพิ่มคีย์ลัดไปไว้ใน Assigned

- ลบคีย์ลัดออกจาก Assigned

Reset All คืนค่าคีย์ลัดทั้งหมดให้เป็นค่ามาตราฐานที่โปรแกรมกำ�หนดมาให้

การเพิ่มคีย์ลัด

	 1. พิมพ์คำ�สั่งที่ต้องการเพิ่มคีย์ลัดลงไปในช่อง Filter เช่น Group

	 2. เลือกคำ�สั่งที่ต้องการจากช่อง Function

	 3. คลิกที่ช่อง Add Shortcut แล้วกดคีย์ที่ต้องการบนแป้นคีย์บอร์ดเช่น Ctrl+G

	 4. คลิกปุ่ม + คีย์ลัดจะถูกนำ�ไปเก็บไว้ในช่อง Assigned

	 5. หลังจากที่กำ�หนดคีย์ลัดให้กับคำ�สั่งต่างๆเสร็จแล้วให้คลิกปุ่ม OK

	 เพื่อความสะดวกและรวดเร็วในการทำ�งาน แนะนำ�ให้เพิ่มคีย์ลัดตามตารางต่อไปนี้

Shortcut Function Shortcut Function

F2 Iso Shift+1 X-Ray

F3 Top Shift+2 Back Line

F4 Front Shift+3 Wireframe

F5 Right Shift+4 Hidden Line

F6 Back Shift+5 Shaded

F7 Left Shift+6 Shaded with Texture

F8 Bottom Shift+7 Monochrome

Ctrl+K Preferences Shift+Ctrl+S Save As...

Ctrl+G Make Group Shift+Ctrl+G Explode

Ctrl+I Import Shift+Ctrl+I Model Info

	 ในส่วนของคำ�สั่ง Back Line จะมีคีย์ที่กำ�หนดมาให้แล้วคือคีย์ K แนะนำ�ให้ลบคีย์เดิมออกเพื่อเก็บคีย์เอาไว้ใช้กับคำ�สั่งอื่นๆ

ที่จะเพิ่มในภายหลัง และหลังจากกำ�หนดค่าเสร็จแล้วเราสามารถที่จะส่งออกค่าได้โดยการคลิกที่ปุ่ม Export แล้วเลือกตำ�แหน่งจัด
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เก็บไฟล์ โดยไฟล์จะมีนามสกุล .dat (ถ้าไม่มีการตั้งชื่อใหม่โปรแกรมจะตั้งชื่อมาตราฐานให้เป็น Preferences.dat) และถ้าต้องการ

นำ�กลับมาใช้ใหม่ก็ให้คลิกเลือกที่ปุ่ม Import แล้วเลือกไฟล์ Preferences ที่เคยบันทึกเก็บเอาไว้

หมายเหตุ: ไฟล์ Preferences จะบันทึกค่าในส่วนของ Shortcut และ File ในหน้าต่าง System Preferences เท่านั้น

การเลือกแม่แบบเพื่อใช้งาน
	 การทำ�งานในโปรแกรม Google SketchUp ไม่ว่าจะเป็นการเปิดโปรแกรมขึ้นมาหรือการสร้างงานใหม่ โปรแกรมจะทำ�การ

เรียกเอาแม่แบบที่ถูกกำ�หนดเอาไว้แล้วมาเป็นแม่แบบเริ่มต้นสำ�หรับการทำ�งาน

	 เราสามารถที่จะเลือกกำ�หนดแม่แบบเริ่มต้นสำ�หรับการทำ�งานได้จากหน้าต่าง System Preferences ในหมวด Template 

หรือเลือกจากหน้าต่าง Welcome to SketchUp ก็ได้เช่นกัน การเรียกแสดงหน้าต่าง Welcome to SketchUp สามารถเลือกได้จาก

เมูน Help > Welcome to SketchUp

การกำ�หนดค่าในส่วนของ Model Info
	 Model Info เป็นส่วนสำ�หรับกำ�หนดรายละเอียดต่างๆของไฟล์งานที่กำ�ลังทำ�งานอยู่ในขณะนั้นเพื่อช่วยให้การทำ�งานมี

ความสะดวกและเหมาะสมกับการทำ�งานในลักษณะต่างๆ ไม่ว่าจะเป็นการกำ�หนดการแสดงผลของแอนิเมชัน การแก้ไข Compo-

nent/Group การกำ�หนดรายละเอียดของไฟล์ หน่วยวัด รูปแบบตัวอักษร เป็นต้น สามารถเรียกหน้าต่าง Model Info ได้จากเมนู Win-

dow > Model Info หรือคลิกที่ไอคอน 

การบันทึกแม่แบบ (Save As Template)
	 เราสามารถบันทึกไฟล์งานเก็บไว้เป็นแม่แบบสำ�หรับใช้งานในครั้งต่อไปได้จากเมนู File > Save As Template... การบันทึก

แม่แบบนั้นจะมีการเก็บค่าต่างๆที่กำ�หนดเอาไว้ในไฟล์งาน ไม่ว่าจะเป็นการกำ�หนดค่าต่างๆใน Model Info มุมมอง หรือรูปแบบการ

แสดงผลเป็นต้น
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Basic Model
การขึ้นโมเดลเก้าอี้แบบง่ายๆ
	 เพื่อให้คุ้นเคยกับการทำ�งานเบื้องต้นก่อนที่จะไปรู้จักกับการใช้งานเครื่องมือแต่ละชนิดอย่าง

ละเอียดเราจะทำ�การขึ้นโมเดลเก้าอี้แบบง่ายๆ โดยในขั้นตอนการขึ้นโมเดลจะได้เรียนรู้การใช้เครื่อง

มือต่างๆในเบื้องต้นเช่น Line, Rectangle, Arc, Move, Tape Measure ไปจนถึงการใส่วัสดุให้กับพื้น

ผิวเป็นต้น

ขั้นตอนการขึ้นโมเดลเก้าอี้

1. สร้างรูปสี่เหลี่ยมขนาด 41 x 50 cm ด้วยเครื่องมือ Line (L) หรือ Rectangle (R)

2. ใช้เครื่องมือ Select (Spacebar) เลือกพื้นผิวด้านล่าง หรือกดคีย์ Ctrl+A

3. เลือกเครื่องมือ Move (M) กดคีย์ Ctrl หนึ่งครั้ง คลิกที่พื้นผิวแล้วลากขึ้นไป

ตามแนวตั้งห่างจากพื้นผิวเดิม 42 cm

4. ใช้เครื่องมือ Push/Pull (P) ดึงพื้นผิวด้านบนขึ้นไป 2 cm เราจะได้ส่วนที่

เป็นแผ่นไม้สำ�หรับใช้เป็นแผ่นรองนั่งของเก้าอี้
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5. ต่อไปเราจะทำ�ขาเก้าอี้โดยใช้เครื่องมือ Offset (F) คัดลอกเส้นขอบของพื้นผิวด้านล่างเข้ามา 2 cm

6. ใช้เครื่องมือ Eraser (E) ลบเส้นรอบนอกทั้งสี่ด้านทิ้งไป

7. ใช้เครื่องมือ Rectangle (R) สร้างรูปสี่เหลี่ยมขนาด 6 x 6 cm ที่มุมทั้งสี่มุมของพื้นผิวด้านล่าง

8. ใช้เครื่องมือ Eraser (E) ลบเส้นขอบของพื้นผิวดานล่างทั้งสี่ด้านทิ้งไป

9. ใช้เครื่องมือ Arc (A) สร้างเส้นโค้งตามมุมต่างๆของรูปสี่เหลี่ยมทั้งสี่รูป แล้วใช้เครื่องมือ Eraser ลบเส้นที่ไม่ต้องการทิ้งไป เราจะได้

แม่แบบสำ�หรับขึ้นขาเก้าอี้ทั้งสี่ขา
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10. ใช้เครื่องมือ Push/Pull (P) ดึงขาเก้าอี้ด้านหน้าทั้งสองขาขึ้นไป 42 cm บรรจบกับพื้นผิวด้านล่างของแผ่นรองนั่ง

11. ใช้เครื่องมือ Push/Pull ดึงขาเก้าอีด้านหลังทั้งสองขาขึ้นไป 90 cm

12. ใช้เครื่องมือ Select (Spacebar) เลือกพื้นผิวด้านล่างและด้านบนของแผ่นรองนั่ง จากนั้นคลิกขวาเลือกคำ�สั่ง Intersect Face > 

With Model เพื่อใช้พื้นผิวที่เลือกทำ� Intersect กับขาเก้าอี้ด้านหลังทั้งสองขา

13. ใช้เครื่องมือ Tape Measure (T) ลากเส้นไกด์จากขอบพนักพิงด้านล่างขึ้นไปด้านบน 19 cm

14. ใช้เครื่องมือ Rectagle (R) สร้างรูปสี่เหลี่ยมที่พื้นผิวด้านข้างของพนักพิงขนาด 2 x 4 cm
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15. ใช้เครื่องมือ Select (Spacebar) เลือกพื้นผิวของรูปสี่เหลี่ยมในข้อ 14 แล้วใช้เครื่องมือ Move (M) กดคีย์ Ctrl หนึ่งครั้ง คัดลอก

รูปสี่เหลี่ยมขึ้นไปด้านบน 7 cm

16. ใช้เครื่องมือ Push/Pull (P) กดคีย์ Ctrl หนึ่งครั้ง แล้วดึงพื้นผิวของรูปสี่เหลี่ยมทั้งสองรูปมาบรรจบกับพนักพิงอีกด้าน

17. ใช้เครื่องมือ Rectangle (R) สร้างรูปสี่เหลี่ยมขนาด 2 x6 cm ที่มุมด้านบนของพนักพิง จากนั้นใช้เครื่องมือ Push/Pull (P) ดึงพื้น

ผิวมาบรรจบกับด้านตรงข้าม

18. ใช้เครื่องมือ Push/Pull ดึงพื้นผิวด้านบนขึ้นไป 1 cm

19. ใช้เครื่องมือ Tape Measure (T) ลากเส้นไกด์จากขอบพนักพิงเข้ามาด้านใน 1 cm ทำ�เหมือนกันทั้งสองด้าน จากนั้นใช้เครื่องมือ 

Arc (A) สร้างเส้นโค้งที่มุมด้านบนทั้งสองด้าน

20. ใช้เครื่องมือ Push/Pull (P) ดันที่ขอบด้นบนของพนักพิงทั้งสองด้านออกไปเพื่อตัดขอบให้โค้งมน
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21. ใช้เทคนิดต่างๆข้างต้นทำ�การสร้างคานยึดขาเก้าอี้ทั้งสามด้าน (ด้านซ้าย ด้านหน้า และด้านขวา) โดยคานยึดจะมีหน้ากว้าง 4 

cm และหนา 2 cm มีความยาวบรรจับกับขาเก้าอี้แต่ละด้าน วางในตำ�แหน่งสูงจากขาเก้าอี้ด้านล่างขึ้นมา 8 cm และห่างจากขอบ

แต่ละด้าน 1 cm

22. ใช้เครื่องมือ Arc (A) และเครื่องมือ Push/Pull (P) ทำ�การลบเหลี่ยมของแผ่นรองนั่งทั้งสี่มุม

23. เลือกเครื่องมือ Paint Bucket (B) เพื่อเปิดหน้าต่าง Meterials ขึ้นมา เลือกชุดรูปแบบวัสดุเป็น Wood แล้วเลือกวัสดุเป็น Wood_

Cherry_Original จากนั้นกดคีย์ Ctrl ค้างไว้แล้วคลิกที่เก้าอี้

24. เลือกเมนู View > Shadow เพื่อให้มีการแสดงผลของเงา

Save, Save As, Save a Copy As และ Save As Template
	 การบันทึกไฟล์งานในโปรแกรม Google SketchUp จะมีอยู่ด้วยกัน 4 รูปแบบ สามารถเรียกใช้งานได้จากเมนู File

Save คือลักษณะการบันทึกไฟล์งานแบบปกติทั่วไป

Save As... คือการบันทึกไฟล์งานที่กำ�ลังทำ�งานอยู่ในขณะนั้นเป็นไฟล์ใหม่ โดยจะมีการตั้งชื่อไฟล์ใหม่และจะทำ�งาน

ต่อกับไฟล์ใหม่

Save A Copy As... คือการบันทึกไฟลืงานที่กำ�ลังทำ�งานอยู่ในขณะนั้นเป็นไฟล์ใหม่ โดยจะมีการตั้งชื่อไฟล์ใหม่แต่จะยังคงทำ�

งานกับไฟล์งานเดิมอยู่

Save As Template คือการบันทึกไฟล์งานเป็นแม่แบบเก็บเอาไว้เพื่อใช้เป็นแม่แบบในการสร้างงานในครั้งต่อไป
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การใช้งานเครื่องมือ Select
การเลือกวัตถุด้วยเครื่องมือ Select
	 วัตถุใน Google SketchUp จะแบ่งออกเป็น 6 รูปแบบด้วยกันคือ เส้น (Edge), พื้นผิว (Face), วัตถุที่ถูกรวมกลุ่ม (Group/

Component), เส้นนำ�หรือเส้นไกด์ (Guide Line), ข้อความ (Text) เส้นวัดขนาด (Dimension Line) และแผ่นหน้าตัด (Section Plane) 

เราสามารถเลือกวัตถุต่างๆเหล่านี้ได้ด้วยเครื่องมือ Select โดยเลือกจากไอคอน  หรือกดคีย์ Spacebar หรือเลือกจากเมนู Tools 

> Select

การเลือกวัตถุด้วยการคลิกเม้าส์

	 การเลือกวัตถุด้วยการคลิกจะแบ่งออกเป็น 3 รูปแบบด้วยกันดังนี้

1. การคลิกเม้าส์ 1 ครั้งที่วัตถุจะเป็นการเลือกเฉพาะวัตถุที่ถูกคลิกเลือกเท่านั้น

2. การดับเบิลคลิกที่วัตถุจะแบ่งย่อยออกเป็น 4 รูปแบบคือ

	 2.1 ดับเบิลคลิกที่พื้นผิวจะเป็นการเลือกพื้นผิวและเส้นที่อยู่รอบพื้นผิวที่ถูกเลือก

	 2.2 ดับเบิลคลิกที่เส้นจะเป็นการเลือกเส้นและพื้นผิวที่อยู่ติดกับเส้นที่ถูกเลือก

	 2.3 ดับเบิลคลิกวัตถุที่เป็น Group/Component จะเข้าสู่โหมดแก้ไข Group/Component

	 2.4 ดับเบิลคลิกที่ข้อความ/เส้นวัดขนาดจะเป็นการแก้ไขข้อความ

	 2.5 ดับเบิลคลิกที่แผ่นหน้าตัดจะเป็นการเปิด/ปิดการทำ�งานของแผ่นหน้าตัด

3. การทริปเปิลคลิกที่วัตถุ (คลิกเม้าส์ 3 ครั้งติดกัน) จะเป็นการเลือกวัตถุทั้งหมดบนรูปทรงเดียวกัน

การเลือกวัตถุด้วยการแดร็กเม้าส์ (Drag Mouse)

	 การแดร็กเม้าส์หรือการคลิกแล้วลากเม้าส์เพื่อเลือกวัตถุจะแบ่งออกเป็น 2 รูปแบบด้วยกันดังนี้

1. การคลิกแล้วลากเม้าส์จากขวาไปซ้าย วัตถุที่อยู่ในขอบเขตของการลากเม้าส์จะถูกเลือกทั้งหมด

2. การคลิกแล้วลากเม้าส์จากซ้ายไปขวา วัตถุที่ขอบเขตของเม้าส์ลากผ่านจะถูกเลือกทั้งหมด

การใช้คีย์ Ctrl, Shift และ Ctrl+Shift ร่วมกับเครื่องมือ Select

	 เราสามารถกดคีย์ Ctrl, Shift และ Ctrl+Shift ร่วมกับการใช้เครื่องมือ Select จะช่วยให้เลือกวัตถุหลายชิ้นเฉพาะส่วนที่ต้อง

การได้โดยมีรูปแบบการใช้งานดังนี้

Ctrl ใช้เพื่อเลือกวัตถุเพิ่ม

Shift ใช้เพื่อลดวัตถุที่ถูกเลือก

Ctrl+Shift ใช้เพื่อเลือก/ลดวัตถุ
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	 นอกจากนี้เรายังสามารถเลือกวัตถุทั้งหมดบนพื้นที่ทำ�งานได้โดยการใช้คำ�สั่ง Edit > Select All หรือกดคีย์ Ctrl+A และ

ยกเลิกการเลือกวัตถุได้ด้วยคำ�สั่ง Edit > Select None หรือกดคีย์ Ctrl+T

หมายเหตุ: ในกรณีที่เข้าสู่โหมดแก้ไข Group/Component การใช้คำ�สั่ง Select All จะเป็นการเลือกเฉพาะวัตถุที่อยู่ใน Group/Com-

ponent เท่านั้น

การเลือกวัตถุจากหน้าต่าง Outliner
	 Outliner เป็นหน้าต่างแสดงรายการวัตถุที่เป็น Group และ Component สามารถใช้เลือกวัตถุที่อยู่ลึกลงไปใน Group/Com-

ponent ได้ (วัตถุที่อยู่ลึกลงไปจะต้องเป็น Group หรือ Component ด้วย) นอกจากนี้ยังสามารถใช้ในการตั้งชื่อใหม่ให้กับวัตถุ และยัง

สามารถเลือกวัตถุที่ถูกซ่อนได้ อีกทั้งยังสามารถคลิกขวาเพื่อเรียกใช้คำ�สั่งต่างๆได้เช่นเดียวกับการเลือกวัตถุบนพื้นที่ทำ�งาน

	 การใช้งาน Outliner โดยส่วนใหญ่จะใช้ในกรณีที่แบบจำ�ลองมีความซับซ้อนและมีวัตถุที่เป็น Group/Component หลายชิ้น 

ซึ่งจะช่วยให้การเข้าถึงวัตถุต่างๆนั้นทำ�ได้ง่ายขึ้น การเปิดหน้าต่าง Outliner สามารถเลือกได้จากเมนู Window > Outliiner

วาดเส้นตรงด้วยเครื่องมือ Line
การวาดเส้นตรงในลักษณะต่างๆ
	 เครื่องมือ Line เป็นเครื่องมือสำ�หรับวาดเส้นตรง สามารถเรียกใช้งานได้จากไอคอน  หรือเลือกจากเมนู Draw > Line หรือ

กดคีย์ L การวาดเส้นตรงด้วยเครื่องมือ Line จะมีรูปแบบการวาดเส้นตรงอยู่ 2 วิธีด้วยกันคือ

1. Click-move-click เป็นการวาดเส้นตรงแบบการคลิกเม้าส์หนึ่งครั้งในตำ�แหน่งเริ่มต้นแล้วเลื่อนเม้าสไปยังตำ�แหน่งถัดไปแล้วคลิก

เม้าส์อีกครั้ง วิธีนี้เมื่อปล่อยเม้าส์แล้วเลื่อนเม้าส์ไปยังตำ�แหน่งใดๆจะมีเส้นตรงเชื่อมต่อจากปลายเส้นที่เพิ่งวาดไปตามเคอร์เซอร์ของ

เม้าส์ออกมาเสมอจนกว่าเส้นจะมีการบรรจบกันจนเกิดเป็นพื้นผิว

2. Click-drack-release เป็นการวาดเส้นตรงแบบการคลิกเม้าส์ในตำ�แหน่งเริ่มต้นค้างไว้แล้วลากไปปล่อยยังตำ�แหน่งที่ต้องการ วิธีนี้

เมื่อปล่อยเม้าส์แล้วการวาดเส้นจิสิ้นสุดลงทันที

	 เราสามารถเลือกกำ�หนดรูปแบบการวาดเส้นตรงได้จากหน้าต่าง 

System Preferecnes / Drawing / Click Style โดยค่ามาตราฐานของ

โปรแกรมจะกำ�หนดรูปแบบการวาดเส้นตรงเป็นแบบ Auto detect ซึ่ง

สามารถวาดเส้นตรงได้ทั้งสองวิธีข้างต้น

Tips: ในขณะที่ทำ�การวาดเส้นตรง สามารถกดคีย์ Esc เพื่อยกเลิกการ

ทำ�งานในขณะนั้น
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การกำ�หนดความยาวของเส้นด้วย Measurement

	 ในขณะที่ใช้เครื่องมือ Line วาดเส้นไปในทิศทางต่างๆให้สังเกตที่เครื่องมือ Measurement จะเห็นว่าข้อความด้านหน้าของ

ช่องกำ�หนดค่าจะเปลี่ยนเป็น Length และในช่องกำ�หนดค่าจะแสดงตัวเลขตามระยะของเส้นที่ถูกลากไป

	 เราสามารถกำ�หนดความยาวของเส้นด้วย Measurement ได้ด้วยกัน 2 กรณีคือ

1. กำ�หนดค่าในขณะที่ลากเส้นไปในทิศทางต่างๆ วิธีนี้หลังจากกำ�หนดค่าเสร็จจะยังคงมีเส้นเชื่อมต่อจากปลายเส้นตามเคอร์เซอร์

ออกมา

2. กำ�หนดค่าหลังจากที่วาดเส้นเสร็จแล้ว วิธีนี้จะทำ�ให้การวาดเส้นสิ้นสุดลงทันทีไม่มีเส้นเชื่อมต่อตามออกมา แต่มีข้อแม้ว่าการ

กำ�หนดค่าจะต้องกำ�หนดหลังจากที่วาดเส้นเสร็จโดยที่ไม่มีการเปลี่ยนไปใช้เครื่องมือใดๆ ยกเว้นเครื่องมือเกี่ยวกับการจัดการมุมมอง

ปรับแต่งความยาวของเส้นด้วย Entity Info

	 ในกรณีที่วาดเส้นเสร็จแล�วแต่ลืมกำ�หนดความยาวของเส้นและมีการเปล่ียนไปใช้เคร่ือง

มือใดๆแล้ว เรายังสามารถที่จะปรับแต่งความยาวของเส้นได้จากหน้าต่าง Entity Info (Window 

> Entity Info) โดยกำ�หนดค่าความยาวของเส้นได้จากช่อง Length

หมายเหตุ: เส้นที่สามารถปรับแต่งด้วย Entity Info ได้นั้น ปลายเส้นด้านใดด้านหนึ่งจะต้องไม่

เชื่อมต่อกับเส้นใดๆ เราจะเรียกเส้นในลักษณะนี้ว่าเส้นเปิด และถ้าเส้นนั้นปลายเส้นทั้งสองด้าน

เชื่อมต่อกับเส้นใดๆ เราจะเรียกเส้นในลักษณะนี้ว่าเส้นปิด

องค์ประกอบของวัตถุใน Google SketchUp
	 วัตถุหรือรูปทรงใน Google SketchUp จะประกอบไปด้วยเส้นและพื้นผิวเป็นหลัก โดยพื้นผิวจะเกิดขึ้นได้ก็ต่อเมื่อมีการ

บรรจบกันของเส้นตั้งแต่ 3 เส้นขึ้นไป ดังนั้นเมื่อใดก็ตามที่เราวาดเส้นมาบรรจบกันในระนาบเดียวกันก็จะเกิดพื้นผิวขึ้นภายใน

ขอบเขตของเส้นเหล่านั้น และในส่วนของพื้นผิวเองจะมีด้วยกันอยู่ 2 ด้านคือ พื้นผิวด้านนอกและพื้นผิวด้านใน

การทำ�งานในมุมมอง 2D และ 3D
	 การทำ�งานในโปรแกรมออกแบบ 3D ทั่วไปจะมีการทำ�งานในมุมมองทั้งแบบ 2D (Two Dimensions) และ 3D (Three Di-

mensions)  โดยการทำ�งานในมุมมองแบบ 2D นั้น การทำ�งานจะอ้างอิงกับเส้นแกน 2 เส้น เช่น x, y หรือ x, z เป็นต้น

	 มุมมองการทำ�งานแบบ 2D จะมีอยู่ด้วยกัน 6 มุมมองคือ ด้านบน (Top) ด้านหน้า (Front) ด้านขวา (Right) ด้านหลัง (Back) 

ด้านซ้าย (Left) และด้านล่าง (Bottom) ซึ่งถ้าเราทำ�งานในมุมมองด้านซ้ายหรือด้านขวาก็จะอ้างอิงการทำ�งานกับแกน y (แกนสีเขียว) 

และแกน z (แกนสีน้ำ�เงิน) เป็นต้น

	 ส่วนสำ�หรับการทำ�งานในรูปแบบ 3D นั้นจะทำ�งานกับแกนอ้างอิงทั้ง 3 แกน คือ x, y และ z ซึ่งก็คือมุมมองแบบ Iso นั่นเอง
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การอ้างอิงทิศทางด้วยแกนอ้างอิง (Axes)

	 การวาดเส้นใน Google SketchUp จะมีการอ้างอิงทิศทางตามแกนอ้างอิง (Axes) ทั้ง 3 แกนเพื่อให้การสร้างเส้นในทิศทาง

ต่างๆมีความถูกต้องและแม่นยำ� โดยถ้าวาดเส้นขนานไปตามแกน x เส้นที่กำ�ลังวาดอยู่จะแสดงเป็นสีแดง หรือถ้าวาดเส้นขนานไป

ตามแกน y เส้นที่กำ�ลังวาดอยู่จะแสดงเป็นสีเขียว เป็นต้น

การย้ายตำ�แหน่งแกนอ้างอิง
	 เราสามารถที่จะย้ายตำ�แหน่งของแกนอ้างอิงและปรับหมุนไปในทิศทางต่างๆได้เพื่อใช้อ้างอิงการสร้างเส้นหรือรูปทรงใน

ทิศทางที่ต้องการ สามารถทำ�ได้โดยเลือกไอคอน  หรือเลือกจากเมนู Tools > Axes หรือจะใช้วิธีคลิกขวาที่แกนอ้างอิงแล้วเลือกคำ�

สั่ง Place ก็ได้เช่นกัน

	 นอกจากนี้เรายังสามารถย้ายแกนอ้างอิงไปยังตำ�แหน่งใดๆโดยการกำ�หนดตำ�แหน่งและทิศทางที่แน่นอนลงไป สามารถทำ�

ได้โดยคลิกขวาที่แกนอ้างอิงแล้วเลือกคำ�สั่ง Move จะปรากฎหน้าต่าง Move Sketching Context ขึ้นมา โดยจะมีตัวเลือกให้กำ�หนด

ค่าทั้งในส่วนของการกำ�หนดตำ�แหน่งและการกำ�หนดองศาของแกนทั้ง 3 แกน

การอ้างอิงตำ�แหน่งด้วย Inference
	 Inference เป็นอีกความสามารถของ Google SketchUp ที่จะช่วยให้การสร้างชิ้นงานในตำ�แหน่งและทิศทางต่างๆสามารถ

กระทำ�ได้ง่ายขึ้น โดย Inference จะแสดงอยู่ในรูปแบบของสัญลักษณ์ต่างๆเช่น จุดสี เส้นทึบ เส้นประสีต่างๆ พร้อมแสดงข้อความที่

จะช่วยให้เรารู้ว่าขณะนั้นกำ�ลังทำ�งานอยู่ที่ตำ�แหน่งไหน และอ้างอิงอยู่กับแกนใด

Inferecne แบบจุด (Point Inference)

	 จะปรากฎให้เห็นตามแนวเส้นและพื้นผิวของชิ้นงานพร้อมข้อความกำ�กับ โดยรูปแบบของจุด สี และข้อความจะแสดงผล

แตกต่างกันออกไป

Inference แบบเส้น (Line Inference)

	 จะปรากฎให้เห็นขณะมีการวาดเส้นไปยังทิศทางต่างๆที่อ้างอิงจากแกนอ้างอิงหรือเส้นตรงบนชิ้นงาน โดย Inference แบบ

2D View 3D View
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เส้นจะแสดงให้เห็นด้วยเส้นที่มีลักษณะแตกต่างกันออกไปพร้อมแสดงข้อความกำ�กับ โดยรูปแบบของเส้น สี และข้อความจะแสดง

ผลแตกต่างกันออกไป

Inference บนพื้นระนาบ (Planar Inference)

	 เป็น Inference ที่จะช่วยให้การสร้างเส้นหรือรูปทรงต่างๆบนพื้นระนาบทำ�ได้ง่ายขึ้น ซึ่งจะหมายถึงการทำ�งานบนพื้นผิวที่มี

ความลาดเอียงในทิศทางต่างๆ รวมไปถึงตำ�แหน่งที่เป็นพื้นดินบนพื้นที่ทำ�งานด้วย

การแบ่งเส้นตรงออกเป็นส่วนๆด้วยคำ�สั่ง Divide
	 เราสามารถแบ่งเส้นตรงออกเป็นส่วนๆที่เท่ากันได้โดยการคลิกขวาที่เส้นที่

ต้องการแล้วเลือกคำ�สั่ง Divide แล้วเลื่อนเม้าส์เพื่อกำ�หนดจำ�นวนการแบ่งเส้น โดย

เลื่อนเม้าส์ไปทางซ้ายจะเป็นการลดจำ�นวนและเลื่อนเม้าส์ไปทางขวาจะเป็นการเพิ่ม

จำ�นวนการแบ่งเส้น หรือจะกำ�หนดค่าด้วย Measurements ก็ได้เช่นกัน

วาดรูปสี่เหลี่ยมด้วยเครื่องมือ Rectangle
การวาดรูปสี่เหลี่ยมทั่วไป
	 Rectangle เป็นเครื่องมือสำ�หรับวาดรูปสี่เหลี่ยม โดยรูปสี่เหลี่ยมที่ได้จะ

ประกอบไปด้วยเส้น 4 เส้นทำ�มุม 90 องศาบรรจบกันและมีพื้นผิวอยู่ด้านใน สามารถ

เรียกใช้งานเครื่องมือ Rectangle ได้โดยคลิกที่ไอคอน  หรือเลือกจากเมนู Draw > 

Rectangle หรือกดคีย์ R

	 การวาดรูปสี่เหลี่ยมด้วยเครื่องมือ Rectangle เราจะใช้วิธีคลิกเม้าส์ลงบน

ตำ�แหน่งที่ต้องการจากนั้นเลื่อนเม้าส์ไปยังทิศทางต่างๆจนได้ขนาดของรูปสี่เหลี่ยมที่

ต้องการแล้วคลิกเม้าส์อีกครั้ง

กำ�หนดขนาดของรูปสี่เหลี่ยมด้วย Measurments

	 การกำ�หนดขนาดของรูปสี่เหลี่ยมด้วย Measurments จะใช้วิธีการพิมพ์ขนาดที่ต้องการลงไป เช่น 5, 8 หรือ 10m, 12m 

เป็นต้น

การวาดรูปสี่เหลี่ยมจตุรัสและสี่เหลี่ยมแบบ Golden
	 ในขณะที่วาดรูปสี่เหลี่ยมด้วยเครื่องมือ Rectangle ถ้าปรากฎเส้นแทยงมุมพร้อมข้อความกำ�กับเป็น Square หรือ Golden 

Section จะเป็น Inference อีกลักษณะหนึ่งที่จะแจ้งให้ผู้ใช้ทราบว่าขณะนั้นรูปสี่เหลี่ยมที่เราวาดเป็นรูปสี่เหลี่ยมจตุรัส หรือเป็นรูป

สี่เหลี่ยมแบบ Golden ซึ่งจะทำ�ให้ง่ายในการสร้างรูปสี่เหลี่ยมทั้งสองแบบ

สี่เหลี่ยมจตุรัส สี่เหลี่ยมแบบ Golden
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ทำ�ความรู้จักกับ Golden Section
	 คำ�ว่า Golden Section เป็นชื่อที่ถูกตั้งใน 2,000 ปีให้หลังในศตวรรษที่ 15 โดย Luca Pacioli และ Leonardo da Vinci เรียก

มันว่า Divine Proportion (สัดส่วนศักดิ์สิทธิ์) คำ�ว่า “Golden” ถูกนำ�มาใช้อีกครั้งในปี 1853 ในหนังสือของนักคณิตศาสตร์ Martin 

Ohm และยิ่งเป็นที่รู้จักกันมากขึ้นในนวนิยายเรื่อง The Da Vinci Code ของแดนบราวน์

	 Golden Section ยังมีชื่อเรียกอีกหลายชื่อดังนี้ Golden Proportion, Golden Ratio, Golden Number, Gonden Mean 

และ Golden Rectangle

	 Golden Section มีสัดส่วน 0.618:1 ซึ่งเท่ากับ 1.64803 39887 49894 84820 ซึ่งถูกเรียกว่า Phi (ตามชื่อนักประติมากรรม

ชาวกรีก Phidias ผู้ปั้นรูปปั้นประดับบนวิหารพาร์เธนอน 440 BC) โดยอนุโลมสัดส่วน 2:3, 5:8, 8:10 และ 89:144 ให้เป็นสัดส่วนที่

สมบูรณ์ ชาวกรีกเชื่อว่ามันเป็นสัดส่วนพื้นฐานของความงามของสรรพสิ่งในจักรวาลและกฎแห่งธรรมชาติ เชื่อกันว่าพีรามิตอียิปต์ก็

สร้างด้วยสัดส่วนนี้

	 Golden Section มีความสัมพันธ์กับเลข Fibonacci Sequence ซึ่งเป็นตัวเลขที่สร้างขึ้นจากการเริ่มต้นที่เลข 0, 1 และต่อ

เนื้องไปด้วยเลขใหม่ที่เป็นผลมาจากผลรวมของเลขสองตัวแรกคือ 0+1 = 1, 1+1 = 2, 1+2 = 3, 2+3 = 5, 3+5 = 8, ... ทำ�ให้เกิดการ

เรียงลำ�ดับของตัวเลข 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, ... ลำ�ดับการเรียงของอัตราส่วนในลักษณะนี้จะให้ค่า 1/1 = 1, 2/1 

= 2, 3/2 = 1.5, 5/3 = 1.666..., 8/5 = 1.6, 13/8 = 1.6525, 21/13 = 1.615..., 34/24 = 1.619, 55/34 = 1.6176, 89/55 = 1.681...

	 Golden Section ถูกนำ�มาใช้ในงานออกแบบต่างๆทั้งในด้านสถาปัตยกรรม การจัดองค์ประกอบของภาพถ่าย การวาดภาพ 

ไปจนถึงนำ�มันมาใช้เป็นสัดส่วนพื้นฐานของร่างกายมนุษย์และกฎแห่งธรรมชาติ

การใช้งานเครื่องมือ Push/Pull
	 Push/Pull เป็นเครื่องมือสำ�หรับใช้ดึงและดันพื้นผิวของวัตถุ เป็นเครื่องมือสำ�คัญอีกชิ้นหนึ่งที่มักถูกเรียกใช้งานเป็นประจำ�

ในการขึ้นโมเดลด้วย Google SketchUp สามารถเรียกใช้งานได้โดยคลิกที่ไอคอน  หรือเลือกได้จากเมนู Tools > Push/Pull หรือ

กดคีย์ P

	 เครื่องมือ Push/Pull จะสามารถทำ�งานได้เฉพาะกับพื้นผิวของวัตถุ โดยจะใช้หลักการในการดึงพื้นผิวขึ้นมา หรือดันพื้นผิว

เข้าไป การดันพื้นผิวสามารถที่จะใช้ในการตัดเจาะวัตถุได้ด้วยโดยการดันให้เสมอพื้นผิวด้านหลังของวัตถุ
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การใช้งานเครื่องมือ Push/Pull ร่วมกับคีย์ Ctrl
	 ในขณะที่ใช้เครื่องมือ Push/Pull ถ้ากดคีย์ Ctrl หนึ่งครั้ง จะเห็นว่าเคอร์เซอร์ของเครื่องมือจะมีเครื่องหมาย + เพิ่มเข้ามา ซึ่ง

จะเป็นการดึงพื้นผิวในลักษณะคัดลอกพื้นผิวเพิ่มขึ้นมา

วัตถุแบบ Solid และ Non Solid
	 ใน Google SketchUp 8 ได้เพิ่มกลุ่มเครื่องมือ Solid ขึ้นมาจึงได้มีการแบ่งรูปแบบของวัตถุออกเป็นแบบ Solid และ Non 

Solid เพื่อให้สามารถใช้งานกับเครื่องมือในกลุ่ม Solid ได้ โดยวัตถุที่เป็นแบบ Solid นั้นจะต้องเป็นรูปทรงสามมิติ ซึ่งพื้นผิวทั้งหมดจะ

ต้องปิดทึบและเชื่อต่อกันทุกด้าน นอกจากนี้วัตถุที่เป็นแบบ Solid จะต้องเป็นวัตถุที่เป็น Group/Component ด้วย

เครื่องมือ Circle และ Polygon
การใช้งานเครื่องมือ Circle
	 Circle เป็นเครื่องมือสำ�หรับสร้างรูปวงกลม สามารถเรียกใช้ได้โดยคลิกที่ไอคอน  หรือเลือกจากเมนู Draw > Circle หรือ

กดคีย์ C

	 การสร้างรูปวงกลมด้วยเครื่องมือ Circle ให้คลิกเม้าส์ลงบนตำ�แหน่งที่

ต้องการแล้วลากเม้าส์ไปยังทิศทางต่างๆจนได้ขนาดที่ต้องการแล้วจึงคลิกเม้าส์อีก

ครั้ง

การใช้งานเครื่องมือ Polygon
	 Polygon เป็นเครื่องมือสำ�หรับสร้างรูปหลายเหลี่ยม สามารถเรียกใช้งานได้

โดยคลิกที่ไอคอน  หรือเลือกจากเมนู Draw > Polygon

	 การสร้างรูปหลายเหลี่ยมด้วยเครื่องมือ Polygon จะมีวิธีการเช่นเดียวกับ

การสร้างรูปวงกลมด้วยเครื่องมือ Circle
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กำ�หนดขนาดของรูปวงกลมและรูปหลายเหลี่ยมด้วย Measurements
	 การกำ�หนดขนาดของรูปวงกลมและรูปหลายเหลี่ยมที่ต้องการด้วยเครื่องมือ Measurements โดยขณะที่ใช้เครื่องมือ Circle 

หรือ Polygon ลากกำ�หนดขนาดจะเห็นว่าข้อความหน้าช่องกำ�หนดค่าจะเปลี่ยนเป็น Radius ซึ่งถ้าเราพิมพ์ค่าที่ต้องการลงไปจะเป็น

การกำ�หนดค่าในส่วนของรัศมีของรูปวงกลมหรือรูปหลายเหลี่ยม เช่นถ้าต้องการวาดรูปวงกลมขนาด 10 cm เราจะพิมพ์ค่าลงไปเป็น 

5 cm ถึงจะได้รูปวงกลมขนาด 10 cm ตามที่เราต้องการ

กำ�หนดจำ�นวนด้านของรูปวงกลมและรูปหลายเหลี่ยมด้วย Measurements
	 จำ�นวนด้านมาตราฐานที่โปรแกรมกำ�หนดมาให้สำ�หรับรูปวงกลมนั้นจะมีจำ�นวนด้านด้วยกัน 24 ด้าน และ 6 ด้านสำ�หรับรูป

หลายเหลี่ยม การกำ�หนดจำ�นวนด้านให้กับรูปวงกลมและรูปหลายเหลี่ยมด้วยเครื่องมือ Measurements สามารถทำ�ได้ด้วยกัน 2 วิธี

ดังนี้

1. หลังจากที่เลือกเครื่องมือ Circle หรือ Polygon ข้อความหน้าช่องกำ�หนดค่าจะเปลี่ยนเป็น Sides ให้พิมพ์จำ�นวนด้านที่ต้องการ

แล้วเคาะ Enter จากนั้นจึงเริ่มสร้างรูปวงกลมหรือรูปหลายเหลี่ยม

2. กำ�หนดค่าหลังจากที่สร้างรูปวงกลมหรือรูปหลายเหลี่ยมเสร็จแล้วโดยพิมพ์จำ�นวนด้านที่ต้องการตามด้วยตัว s เช่น 32s เป็นต้น

ปรับแต่งรูปวงกลมและรูปหลายเหลี่ยมด้วย Entity Info
	 เราสามารถปรับแต่งขนาดและจำ�นวนด้านของรูปวงกลมและรูปหลายเหล่ียม

ได้จากหน้าต่าง Entity Info โดยการปรับแต่งนั้นให้คลิกที่เส้นรอบวงของรูปวงกลมหรือ

รูปหลายเหลี่ยม แล้วปรับเปลี่ยนขนาดได้จากการกำ�หนดค่าในช่อง Radius และกำ�หนด

จำ�นวนด้านได้จากช่อง Segments

Tips: การสร้างรูปวงกลมและรูปหลายเหลี่ยมในแนวระนาบต่างๆจะใช้วิธีการล็อคแนว

ระนาบโดยการเลื่อนเม้าส์ไปยังแนวระนาบที่ต้องการแล้วกดคีย์ Shift ค้างไว้ จากนั้น

เลื่อนเม้าส์มาสร้างวงกลมในตำ�แหน่งที่ต้องการ

การใช้งานเครื่องมือ Arc และ Freehand
สร้างเส้นโค้งด้วยเครื่องมือ Arc
	 Arc เป็นเครื่องมือสำ�หรับสร้างเส้นโค้ง สามารถเรียกใช้งานได้โดยคลิกที่ไอคอน  หรือเลือกจากเมนู Draw > Arc หรือ

กดคีย์ A การสร้างเส้นโค้งด้วยเครื่องมือ Arc จะใช้การคลิกทั้งหมด 3 ครั้งด้วยกันโดยการคลิกครั้งแรกเพื่อกำ�หนดตำ�แหน่งเริ่มต้น

ของการวาด จากนั้นเลื่อนเม้าส์ไปยังทิศทางที่ต้องการแล้วคลิกเม้าส์อีกครั้งเพื่อกำ�หนดความกว้าง แล้วเลื่อนเม้าส์อีกครั้งเพื่อกำ�หนด

ความนูนของเส้นโค้งแล้วจึงคลิกเม้าส์เพื่อสิ้นสุดการสร้างเส้นโค้ง
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	 จำ�นวนด้านมาตราฐานของเส้นโค้งจะถูกกำ�หนดมาให้ที่ 12 ด้าน สามารถกำ�หนดค่าและปรับแต่งได้เหมือนกับการใช้เครื่อง

มือ Circle และ Polygon โดยใช้เครื่องมือ Measurements และ Entity Info

สร้างเส้นอิสระด้วยเครื่องมือ Freehand
	 เครื่องมือ Freehand เป็นเครื่องมือสำ�หรับสร้างเส้นอิสระ โดยส่วนใหญ่จะเอาไว้ใช้ในการสร้างลักษณะของภูมิประเทศใน

การเขียนแบบ 2D หรือใช้ร่วมกับเครื่องมือในกลุ่ม Sandbox เพื่อสร้างลักษณะภูมิประเทศแบบ 3D

	 การเรียกใช้งานเครื่องมือ Freehand ให้คลิกที่ไอคอน  หรือเลือกจากเมนู Draw > Freehand โดยการวาดเส้นอิสระด้วย

เครื่องมือ Freehand จะใช้การคลิกเม้าส์ค้างไว้แล้วลากเส้นเป็นรูปทรงที่ต้องการแล้วจึงปล่อยเม้าส์ ซึ่งถ้าเส้นที่วาดนั้นวาดมาบรรจบ

กันหรือตัดผ่านกันก็จะมีการสร้างพื้นผิวขึ้นมาให้ด้วย

การใช้งานเครื่องมือ Eraser
	 เครื่องมือ Eraser เป็นเครื่องมือสำ�หรับใช้ลบวัตถุต่างๆบนพื้นที่ทำ�งาน สามารถเรียกใช้งานได้โดยคลิกที่ไอคอน  หรือ

เลือกจากเมนู Tools > Eraser หรือกดคีย์ E โดยการใช้งานเครื่องมือ Eraser นั้นหลังจากที่เลือกเครื่องมือแล้วก็ให้เลื่อนเม้าส์ไปคลิก

วัตถุที่ต้องการลบทีละชิ้น หรือจะใช้การคลิกเม้าส์ค้างแล้วลากเม้าส์ผ่านไปยังวัตถุที่ต้องการลบ วัตถุที่ถูกลากผ่านจะถูกไฮไลท์และ

หลังจากที่ปล่อยเม้าส์วัตถุเหล่านั้นจะถูกลบออกไป

	 นอกจากการลบวัตถุด้วยเครื่องมือ Eraser แล้วเรายังสามารถที่จะคลิกที่ไอคอน  หรือกดคีย์ Delete (Edit > Delete) เพื่อ

ลบวัตถุที่ถูกเลือกอยู่ในขณะนั้นออกไป หรือจะใช้วิธีคลิกขวาที่วัตถุแล้วเลือกคำ�สั่ง Eraser ก็ได้เช่นกัน 

Tips: เราสามารถใช้คีย์ Shift และ Ctrl ร่วมกับเครื่องมือ Eraser ซึ่งจะทำ�งานเฉพาะกับวัตถุที่เป็นเส้นเท่านั้น โดยการใช้งานเครื่องมือ 

Delete ร่วมกับคีย์ Shift จะเป็นการซ่อนเส้น การใช้ร่วมกับคีย์ Ctrl จะทำ�ให้เส้นนั้นเรียบเนียน และถ้าใช้งานร่วมกับคีย์ Shift+Ctrl จะ

ทำ�ให้เส้นที่เรียบเนียนกลับมาเป็นเส้นปกติ (เฉพาะเส้นขอบของพื้นผิว)

หมายเหตุ: การใช้เครื่องมือ Eraser เพื่อลบวัตถุนั้นจะสามารถใช้ลบวัตถุได้เฉพาะเส้นกับวัตถุที่เป็น Group/Component เท่านั้น 

โดยการลบเส้นถ้าเป็นเส้นขอบของพื้นผิวจะทำ�ให้พื้นผิวที่อยู่ภายในเส้นนั้นถูกลบไปด้วย แต่ถ้าเส้นนั้นเป็นเส้นตัดแบ่งพื้นผิวการลบ

เส้นจะลบเฉพาะเส้นเท่านั้นซึ่งจะทำ�ให้พื้นผิวที่ถูกตัดแบ่งนั้นกลายเป็นพื้นผิวเดียวกัน และถ้าต้องการลบเฉพาะพื้นผิวจะใช้วิธีการ

คลิกขวาที่พื้นผิวแล้วเลือกคำ�สั่ง Eraser หรือจะใช้เครื่องมือ Select (Spacebar) คลิกเลือกที่พื้นผิวแล้วกดคีย์ Delete ก็ได้ (การลบ

เฉพาะพื้นผิวเส้นที่อยู่รอบพื้นผิวจะยงคงอยู่)
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การใช้งานเครื่องมือ Move & Rotate
ย้ายวัตถุด้วยเครื่องมือ Move
	 เครื่องมือ Move เป็นเครื่องมือสำ�หรับใช้เคลื่อนย้ายวัตถุไปยังตำ�แหน่งต่างๆ สามารถเรียกใช้งานได้จากไอคอน  หรือ

เรียกจากเมนู Tools > Move หรือกดคีย์ M การเคลื่อนย้ายวัตถุด้วยเครื่องมือ Move จะมีรูปแบบการทำ�งานด้วยกัน 2 รูปแบบดังนี้

1. ใช้เครื่องมือ Select เลือกวัตถุที่ต้องการ จากนั้นจึงใช้เครื่องมือ Move เคลื่อนย้ายวัตถุไปยังตำ�แหน่งที่ต้องการ

2. ใช้เครื่องมือ Move คลิกที่วัตถุแล้วย้ายไปยังตำ�แหน่งที่ต้องการ

	 วัตถุที่ถูกย้ายด้วยเครื่องมือ Move จะแตกต่างกันไปตามลักษณะของวัตถุที่ถูกเลือกเช่น ถ้าเคลื่อนย้ายพื้นผิว เส้นรอบนอก

ของพื้นผิวจะถูกย้ายตามไปด้วย หรือถ้าเคลื่อนย้ายเส้นขอบของพ้ืนผิวเส้นเดียว พื้นผิวก็จะขยายหรือลดตามทิศทางที่เส้นถูกเคลื่อน

ย้ายไปเป็นต้น

การหมุนวัตถุด้วยเครื่องมือ Move

	 การใช้งานเครื่องมือ Move กับวัตถุที่เป็น Group/Component เมื่อเลื่อนเม้าส์ไปยังด้านใดๆของวัตถุจะปรากฎเครื่องหมาย 

+ สีแดง และถ้าเลื่อนเม้าส์ไปที่เครื่องหมาย + เคอร์เซอร์จะถูกเปลี่ยนเป็นเครื่องมือ Rotate ชั่วคราวพร้อมกับแสดงรูปไม้โปรฯสีแดง 

ซึ่งถ้าเราคลิกเม้าส์ก็จะสามารถปรับหมุนวัตถุได้ทันที

Tips: การหมุนวัตถุด้วยเครื่องมือ Move สามารถที่จะกำ�หนดองศาที่ต้องการลงไปได้ โดยให้สังเกตที่ช่องกำ�หนดค่าของ Measure-

ments จะเปลี่ยนเป็น Angle โดยค่าเป็นบวกจะทำ�ให้วัตถุหมุนทวนเข็มนาฬิกา และถ้าค่าเป็นลบจะทำ�ให้วัตถุหมุนตามเข็มนาฬิกา 

เช่น ถ้ากำ�หนดค่าลงไปเป็น 30 วัตถุจะหมุนทวนเข็มนาฬิกาไป 30 องศา หรือ -15 วัตถุจะหมุนตามเข็มนาฬิกาไป 15 องศาเป็นต้น
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หมุนวัตถุด้วยเครื่องมือ Rotate
	 เครื่องมือ Ratate เป็นเครื่องมือสำ�หรับหมุนวัตถุ สามารถเรียกใช้งานได้จากไอคอน  หรือเรียกจากเมนู Tools > Rotate 

หรือกดคีย์ Q การหมุนวัตถุด้วยเครื่องมือ Rotate จะมีรูปแบบการทำ�งานด้วยกัน 2 รูปแบบดังนี้

1. ใช้เครื่องมือ Select เลือกวัตถุที่ต้องการ จากนั้นจึงใช้เครื่องมือ Rotate ทำ�การปรับหมุนวัตถุ

2. ใช้เครื่องมือ Rotate คลิกที่วัตถุแล้วปรับหมุนไปยังทิศทางที่ต้องการ

	 การหมุนวัตถุด้วยเครื่องมือ Rotate จะใช้การคลิก 3 ครั้งด้วยกันโดยการคลิกครั้งที่ 1 เพื่อกำ�หนดตำ�แหน่ง (จุดศูนย์กลางของ

องศา) คลิกครั้งที่ 2 เพื่อกำ�หนดทิศทางเริ่มต้น (ค่าขององศาเท่ากับ 0 ) แล้วปรับหมุนไปยังทิศทางที่ต้องการ และคลิกครั้งที่ 3 เพื่อกำ�

หนดตำ�แหน่งสุดท้ายให้กับการหมุนวัตถุ

คัดลอกวัตถุด้วยเครื่องมือ Move และ Rotate
	 เครื่องมือ Move และ Rotate ยังมีความสามารถในการใช้คัดลอกวัตถุที่ต้องการได้โดยใช้งานร่วมกับการกดคีย์ Ctrl เพื่อคัด

ลอกวัตถุที่ต้องการ สามารถคัดลอกวัตถุทีละชิ้นหรือหลายชิ้นก็ได้

การคัดลอกวัตถุทีละชิ้น

	 ขณะที่ใช้เครื่องมือ Move ย้ายวัตถุ หรือใช้เครื่องมือ Rotate หมุนวัตถุให้กดคีย์ Ctrl หนึ่งครั้งจะเป็นการคัดลอกวัตถุชิ้นน้ัน

ออกไป (เคอร์เซอร์ของเครื่องมือจะมีเครื่องหมาย + เพิ่มขึ้นมา) โดยขณะใช้เครื่องมือ Move เราจะได้วัตถุเพิ่มขึ้นและเลือกจัดวางใน

ตำ�แหน่งที่ต้องการ และขณะที่ใช้เครื่องมือ Rotate จะได้วัตถุเพิ่มขึ้นและหมุนไปจัดวางในตำ�แหน่งที่ต้องการ

กดคีย์ Ctrl ขณะใช้งานเครื่องมือ Move กดคีย์ Ctrl ขณะใช้งานเครื่องมือ Rotate
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การคัดลอกวัตถุทีละหลายชิ้น

	 การคัดลอกวัตถุทีละหลายชิ้นจะมีอยู่ 2 ลักษณะด้วยกันคือ

1. การคัดลอกวัตถุแบบเพิ่มระยะ วัตถุที่ถูกคัดลอกจะเพิ่มออกไปในทิศทางที่กำ�หนดและมีระยะห่างของวัตถุที่เท่ากัน โดยหลังจาก

คัดลอกวัตถุแบบปกติแล้วให้พิมพ์ค่าลงไปใน Measurements ด้วยเครื่องหมาย * และจำ�นวนที่ต้องการคัดลอก เช่น *5 เป็นต้น 

การคัดลอกในลักษณะนี้นำ�ระยะห่างหรือองศาของวัตถุต้นแบบกับวัตถุที่ถูกคัดลอกออกไปชิ้นแรกเป็นตัวตั้งและคูณด้วยจำ�นวนที่

ต้องการ วัตถุจะถูกคัดลอกเพิ่มออกไปเป็นระยะตามระยะห่างของตัวตั้ง 

2. การคัดลอกวัตถุแบบแบ่งระยะ วัตถุจะถูกคัดลอกภายในระยะห่างของวัตถุต้นแบบกับวัตถุที่ถูกคัดลอก โดยหลังจากคัดลอกวัตถุ

โดยกำ�หนดทิศทางหรือองศาเสร็จแล้วให้พิมพ์ค่าลงไปใน Measurements ด้วยเครื่องหมาย / และจำ�นวนที่ต้องการคัดลอก เช่น /4 

เป็นต้น การคัดลอกในลักษณะนี้จะนำ�ระยะห่างของวัตถุต้นแบบกับวัตถุที่ถูกคัดลอกชิ้นแรกเป็นตัวตั้งและหารด้วยจำ�นวนที่ต้องการ 

วัตถุจะถูกคัดลอกเพิ่มเข้ามาระหว่างวัตถุต้นแบบกับวัตถุที่ถูกคัดลอกชิ้นแรกโดยแบ่งระยะห่างที่เท่ากัน

รู้จักกับ Auto-Fold
	 Auto-Fold เป็นอีกหนึ่งความสามารถใน Google SketchUp เป็นลักษณะการหักมุมของพื้นผิวอัตโนมัติเมื่อมีการเคลื่อน

ย้ายหรือปรับหมุนวัตถุโดยที่วัตถุนั้นจะต้องไม่เป็น Group/Component ยกตัวอย่างเช่น ถ้าเราวาดรูปสี่เหลี่ยมขึ้นมา 1 รูปแล้วใช้

เครื่องมือ Line ลากเส้นแบ่งวัตถุนั้นออกเป็น 2 ส่วน จากนั้นใช้เครื่องมือ Move คลิกที่เส้นแบ่งแล้วดึงขึ้นไปด้านบนตามแกน z จะเห็น

ว่าเส้นจะถูกดึงขึ้นไปด้านบนพร้อมกับพื้นผิวที่ถูกตัดแบ่งนั้นจะถูกหักมุมโดยอัตโนมัติเป็นต้น

ภาพตัวอย่างการทำ�  Auto-Fold ในลักษณะต่างๆ
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	 ในบางครั้งเราอาจจะไม่สามารถทำ� Auto-Fold ได้เนื่องจากความสามารถของ Inference บนพื้นระนาบที่จะทำ�ให้การ

เคลื่อนย้ายวัตถุบนพื้นผิวจะไปตามแนวระนาบของพื้นผิวนั้น (จะเกิดขึ้นกับการวาดรูปทรงภายในพื้นผิวและใช้เครื่องมือ Move เพื่อ

เคลื่อนย้ายวัตถุ) เราจะแก้ปัญหาโดยการกดคีย์ Alt หรือคีย์ลูกศรช่วย โดยในขณะที่ใช้เครื่องมือ Move คลิกลากวัตถุให้กดคีย์ Alt หรือ

คีย์ลูกศรหนึ่งครั้ง เคอร์เซอร์ของเครื่องมือ Move จะเปลี่ยนเป็น  ก็จะสามารถดึงวัตถุเพื่อทำ� Auto-Fold ได้

หมายเหตุ: การกดคีย์ลูกศรเพื่อทำ� Auto-Fold การกดคีย์จะขึ้นอยู่กับว่าวัตถุที่ต้องการทำ� Auto-Fold นั้นอยู่ในทิศทางใดเช่น ถ้าวัตถุ

อยู่ที่ด้านบนเราจะใช้การกดคีย์ลูกศรขึ้น หรือถ้าวัตถุอยู่ด้านข้างเราจะใช้การกดคีย์ลูกศรซ้ายหรือขวาเป็นต้น

Tips: การทำ� Auto-Fold กับรูปทรงที่ขึ้นจากเครื่องมือ Circle หรือ Polygon ในขณะที่ใช้เครื่องมือ Move ให้เลื่อนเม้าส์ไปที่เส้นขอบ

ของรูปในตำ�แหน่ง Endpoint โดยเส้นขอบจะต้องไม่ถูกไฮไลท์แล้วจึงคลิกเม้าส์เพื่อทำ� Auto-Fold

การใช้งานเครื่องมือ Follow Me
	 Follow Me เป็นเครื่องมือสำ�หรับปรับแต่งโมเดล และใช้ขึ้นรูปทรงต่างๆได้ สามารถเรียกใช้งานได้จากไอคอน  หรือเรียก

จากเมนู Tools > Follow Me การใช้งานเครื่องมือ Follow Me บนวัตถุจะมีลักษณะคล้ายๆกับการใช้เครื่องมือ Push/Pull จะแตกต่าง

กันตรงที่เครื่องมือ Follow Me นั้นจะวิ่งไปตามเส้นขอบของวัตถุตามทิศทางที่กำ�หนด

(ซ้าย) ไม่สามารถทำ�  Auto-Fold ได้ (ขวา) หลังจากกดคีย์ Alt แล้วสามารถทำ�  Auto-Fold ได้

(ซ้าย) ตำ�แหน่ง Endpoint ที่ไม่สามารถทำ�  Auto-Fold ได้ (กลาง) ตำ�แหน่ง Endpoint ที่สามารถทำ�  Auto-Fold ได้ (ขวา) หลังจากทำ�  Auto-Fold

(ซ้าย) การใช้งาน Push/Pull ตัดมุมวัตถุ (กลาง) การใช้ Follow We ตัดมุมวัตถุ (ขวา) วัตถุหลังจากใช้ Follow Me ตัดมุม
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การลบมุมของวัตถุให้โค้งมน
	 ตัวอย่างนี้จะเป็นเทคนิคง่ายๆในการใช้เครื่องมือ Follow Me และ Arc ทำ�การลบมุมของรูปทรงสี่เหลี่ยมด้านบนให้โค้งมน 

โดยมีขั้นตอนดังนี้

1. สร้างรูปทรงสี่เหลี่ยมขึ้นมาหนึ่งรูป แล้วใช้เครื่องมือ Arc (A) สร้างเส้นโค้งที่มุมด้าน

บนของรูปทรงสี่เหลี่ยม

2. ใช้เครื่องมือ Follow Me คลิก 1 ครั้งที่พื้นผิวตรงมุมด้านบนแล้วลากเม้าส์ไปรอบๆตามขอบจนมาบรรจบกันแล้วให้คลิกเม้าส์อีกครั้ง

จะเห็นว่ามุมด้านบนของวัตถุจะหายไปและมีความโค้งมนตามที่เรากำ�หนดต้นแบบไว้ในข้อ 1

3. กดคีย์ Ctrl+Z เพื่อย้อนกลับการทำ�งานไปก่อนหน้านี้ จากนั้นให้ใช้เครื่องมือ Select (Spacebar) เลือกเส้นขอบด้านบนทั้ง 4 เส้น

4. เลือกเครื่องมือ Follow Me เคอร์เซอร์ของเครื่องมือจะเปลี่ยนเป็นรูปเครื่องมือ Push/Pull (ตรงนี้น่าจะเป็นบั๊กของโปรแกรม เพราะ

ในเวอร์ชันก่อนๆจะไม่เปลี่ยน) แล้วคลิกที่พื้นผิวตรงมุมด้านบนของรูปทรงสี่เหลี่ยม ทันทีที่คลิกมุมของวัตถุจะถูกลบออกไปทันที

5. ต่อไปให้สร้างรูปดังตัวอย่างที่มุมด้านล่างของพื้นผิวโดยสร้างไว้ที่ด้านนอก แล้วลบเส้นขอบด้านบนและด้านขวาออกไป เราจะใช้

ภาพที่สร้างขึ้นนี้เป็นต้นแบบสำ�หรับทำ�ฐานของรูปทรงสี่เหลี่ยม
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6. ใช้เครื่องมือ Select คลิกเลือกที่พื้นผิวด้านล่างแล้วใช้เครื่องมือ Follow Me คลิกที่รูปต้นแบบที่สร้างขึ้นเราก็จะได้ฐานของรูปทรง

สี่เหลี่ยมตามต้นแบบที่สร้างขึ้น

หมายเหตุ: รูปที่ใช้เป็นต้นแบบในการทำ�งานกับเครื่องมือ Follow Me ในโปรแกรม Google SketchUp จะถูกเรียกว่าโปรไฟล์ (Pro-

file)

การขึ้นรูปทรงกลมและรูปทรงครึ่งวงกลม
	 ในโปรแกรม Google SketchUp จะไม่มีเครื่องมือสำ�เร็จรูปในการขึ้นรูปทรงต่างๆเหมือนในโปรแกรม 3D ทั่วไป ดังนั้นการขึ้น

รูปทรงกลม (Sphere) และรูปทรงครึ่งวงกลมจะใช้ความสามารถของเครื่องมือ Follow Me ในการขึ้นรูปทรง

การขึ้นรูปทรงกลม

1. ปรับมุมมองของพื้นที่ทำ�งานไปเป็นมุมมองด้านหน้าแล้วสร้างรูปวงกลมในแนวตั้งด้วยเครื่องมือ Circle (C)

2. ปรับมุมมองไปเป็นแบบ Iso แล้วสร้างรูปวงกลมในแนวระนาบของแกน x และแกน y ต่ำ�ลงไปจากวงกลมรูปแรกพอประมาณ

3. ใช้เครื่องมือ Select (Spacebar) คลิกที่เส้นรอบนอกของรูปวงกลมด้านล่าง

4. ใช้เครื่องมือ Follow Me คลิกที่พื้นผิวของรูปวงกลมรูปบน เราก็จะได้รูปทรงกลมตามต้องการ

หมายเหตุ: ในกรณีที่ขึ้นรูปทรงกลมแล้วพื้นผิวด้านหน้าด้านหลังเกิดสลับด้านกันก็ให้คลิกเม้าส์ขวาที่รูปทรงกลมแล้วเลือกคำ�สั่ง Re-

verse Faces จะเป็นการสลับด้านของพื้นผิว
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การขึ้นรูปทรงครึ่งวงกลม

1. จากขั้นตอนการขึ้นรูปวงกลมในขั้นตอนที่ 2 เราจะใช้วิธีแบ่งครึ่งรูป

วงกลมรูปใหญ่ออกเป็น 1/2 หรือ 1/4 ส่วนก็ได้โดยใช้เครื่องมือ Line 

(L) ในการแบ่งส่วน

2. ใช้เครื่องมือ Select เลือกพื้นผิวของรูปวงกลมด้านล่างแล้วใช้

เครื่องมือ Follow Me คลิกที่รูปโปรไฟล์ด้านบนเราก็จะได้รูปทรงครึ่ง

วงกลมตามต้องการ

หมายเหตุ: การคลิกเลือกที่เส้นรอบพื้นผิวกับการคลิกเลือกที่พ้ืนผิว

แล้วใช้เครื่องมือ Follow Me คลิกที่รูปโปรไฟล์จะให้ผลลัพธ์ที่เหมือน

กัน ยกเว้นการคลิกเลือกเฉพาะเส้นที่ต้องการโดยเส้นที่ถูกเลือกจะ

ต้องเป็นเส้นที่เชื่อมต่อกัน 

ขึ้นรูปทรงด้วยเครื่องมือ Follow Me ตามเส้น Path
	 เครื่องมือ Follow Me นอกจากจะขึ้นรูปทรงตามเส้นรอบพื้นผิวแล้วยังสามารถที่จะใช้ได้กับเส้นเดี่ยวๆที่ไม่มีพื้นผิวได้อีกด้วย 

วิธีนี้จะเรียกเส้นเหล่านนี้ว่าเส้น Path โดยจะใช้เป็นเส้นนำ�ทางให้กับโปรไฟล์ในการขึ้นรูปทรง

สร้างสปริงจากเส้น Patch

1. วาดรูปครึ่งวงกลมขึ้นมา 1 รูป แล้วกดคีย์ Ctrl+A เพื่อเลือกวัตถุทั้งหมด

2. ใช้เครื่องมือ Rotate ปรับมุมมองและเลื่อนเม้าส์จนรูปไม้โปรฯเปลี่ยนเป็นสีเขียว กดคีย์ Shift ค้างไว้เพื่อล็อคทิศทางแล้วคลิกเม้าส์ที่

มุมด้านซ้ายของรูปครึ่งวงกลม จากนั้นปรับหมุนวัตถุให้เอียงขึ้นไป 10 องศา

3. ใช้เครื่องมือ Move คัดลอกรูปครึ่งวงกลมเพิ่มขึ้นมาอีก 1 รูป

4. คลิกขวาที่รูปครึ่งวงกลมรูปใหม่แล้วใช้คำ�สั่ง Flip Along > Green Direction แล้วตามด้วยคำ�สั่ง Flip Along > Red Direction

SketchUp 8 Handbook.indd   30 26/4/2554   10:22:04



Google SketchUp 8 Handbook 31 

5. ใช้เครื่องมือ Move คลิกที่มุมด้านขวาของรูปครึ่งวงกลมรูปใหม่แล้วลากขึ้นไปชนกับมุมด้านขวาบนของรูปครึ่งวงกลมรูปเดิม

6. ใช้เครื่องมือ Eraser ลบเส้นตรงของรูปวงกลมทั้งสองรูปทิ้งไป

7. เลือกเส้นทั้งสองเส้นแล้วใช้เครื่องมือ Move คลิกที่ปลายเส้นด้านล่างแล้วคัดลอกขึ้นไปชนกับปลายเส้นด้านบน พิมพ์ค่า *4 เพื่อคัด

ลอกเส้นเพิ่มขึ้นไปอีก 4 ชุด

8. ใช้เครื่องมือ Circle สร้างรูปวงกลมที่ปลายเส้นด้านล่าง

9. ใช้เครื่องมือ Select เลือกเส้น Path ทั้งหมดแล้วใช้เครื่องมือ Follow Me คลิกที่รูปวงกลมด้านล่าง เพียงเท่านี้เราก็จะได้รูปทรงสปริง 

ที่เกิดจากการใช้เครื่องมือ Follow Me ขึ้นรูปทรงตามเส้น Path
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เครื่องมือ Tape Measure และ Protractor
การใช้งานเครื่องมือ Tape Measure
	 เครื่องมือ Tape Measure เป็นเครื่องมือที่ใช้สำ�หรับวัดระยะ และสร้างเส้นไกด์ อีกทั้งยังสามารถใช้ในการปรับเปลี่ยนขนาด

ของวัตถุได้ด้วย สามารถเรียกใช้งานได้จากไอคอน  หรือเรียกจากเมนู Tools > Tape Measure หรือกดคีย์ T

การสร้างเส้น Guide

	 การใช้เครื่องมือ Tape Measure สร้างเส้นไกด์จะใช้วิธีคลิกที่เส้นซึ่งจะใช้เป็น

ตำ�แหน่งเริ่มต้นเพื่อใช้กำ�หนดระยะห่าง จากนั้นลากเม้าส์ออกไปจนได้ระยะที่ต้องการแล้ว

คลิกเม้าส์ โดยเส้นไกด์จะวางอยู่ในแนวขนานกับเส้นที่ลากออกมาเสมอ

Tip: เราสามารถใช้เครื่องมือ Tape Measure ดับเบิลคลิกที่เส้นเพื่อสร้างเส้นไกด์ในแนว

ของเส้นนั้น

หมายเหตุ: การใช้เครื่องมือ Tape Measure คลิกตำ�แหน่งเริ่มต้นในตำ�แหน่งปลายเส้น 

หรือจุดเชื่อมต่อของเส้น จะเป็นการสร้างเส้นไกด์จากตำ�แหน่งนั้นยาวไปในทิศทางต่างๆ

การวัดระยะ

	 หลังจากที่คลิกเลือกเครื่องมือ Tape Measure ให้สังเกตว่าที่เคอร์เซอร์ของเครื่องมือจะมีเครื่องหมาย + อยู่ด้วยซึ่งเครื่องมือ

จะพร้อมสำ�หรับการสร้างเส้นไกด์ แต่ถ้าเราต้องการที่จะทำ�การวัดระยะเราจะใช้วิธีการกดคีย์ Ctrl หนึ่งครั้งเครื่องหมาย + ที่เคอร์เซอร์

ของเครื่องมือจะหายไป (การกดคีย์ Ctrl จะเป็นการสลับระหว่างการวัดระยะกับการสร้างเส้นไกด์)

การใช้ Tape Measure ปรับขนาดของวัตถุ

	 การปรับขนาดวัตถุจะใช้วิธีคลิกจุดเริ่มต้นที่เป็นจุดปลายหรือจุดเชื่อมต่อของเส้นหนึ่งครั้งแล้วลากเม้าส์ไปคลิกยังจุดปลาย

หรือจุดเชื่อมต่อของเส้นที่ต้องการ จากนั้นพิมพ์ขนาดที่ต้องการลงไปใน Measurements แล้วเคาะ Enter จะมี Dialog ขึ้นมาแจ้ง

ยืนยันการปรับขนาด ถ้าต้องการปรับขนาดให้คลิกปุ่ม Yes และถ้าไม่ต้องการให้คลิกปุ่ม No

	 จากภาพตัวอย่างเราจะคลิกจากมุมของประตูด้านหนึ่งมายังอีกด้านหนึ่งซึ่งมีความกว้างอยู่ที่ 0.8723 เมตร (ภาพซ้าย) จาก

นั้นเมื่อพิมพ์ค่าลงไปเป็น 1 เมตรแล้วเคาะ Enter จะพบกับ Dialog ยืนยัน คลิกปุ่ม Yes (ภาพกลาง) จะเห็นว่าหลังจากคลิกปุ่ม Yes 
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แล้วความกว้างของประตูจะเปลี่ยนไปเป็น 1 เมตรตามที่เรากำ�หนด (ภาพขวา) วิธีนี้จะทำ�ให้วัตถุทั้งหมดในพื้นที่ทำ�งานถูกปรับขนาด

ตามไปด้วย และถ้าต้องการปรับขนาดเฉพาะประตูโดยไม่ให้ขนาดของบ้านเปลี่ยนไปจำ�เป็นที่จะต้องทำ�ประตูให้เป็น Group หรือ 

Component แล้วเข้าไปในโหมดแก้ไข Group/Component แล้วจึงทำ�การปรับขนาด	
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